Page 1 of 1

Could use some pointers on semi working CN70

PostPosted: Sun Nov 05, 2017 9:51 pm
by Purity_Control
Probably mainly a query for Clav but any useful input appreciated.

So I managed to get my mitts on a used Yamaha CN70 single manual organ for £20, condition looks like it was never played only there's a issue, hence the price.

The sound works for 4 or 5 seconds after power up then fades away to be very quiet, too quite to be able to just turn the volume up as there's then a lot of noise and hum.

My first thought is to open it up and give it a thorough clean and check for loose wires and any obvious damage.

If that doesn't work, i'm guessing the fading thing is probably old caps? This was new around 1979 so not that surprising, would have to have a look so see if I'm up to swapping those out.

Wondering hat else is orth paying close attention to?

Re: Could use some pointers on semi working CN70

PostPosted: Mon Nov 06, 2017 1:38 am
by ClavAnother
Do you ever go to the Organ Forum?

http://www.organforum.com/forums/showth ... maha-CN-70

Also low volume seems to be semi common.

Re: Could use some pointers on semi working CN70

PostPosted: Mon Nov 06, 2017 7:50 am
by Purity_Control
No, but maybe it's time I started to! :grin:

Got to scarper or work, will have a look at that later.

Re: Could use some pointers on semi working CN70

PostPosted: Mon Nov 06, 2017 5:13 pm
by ElectricPuppy
I'm thinking caps. If turning it up just gives more noise/hum, I'm thinking the output amp may be OK, but something is choking the input to it. Maybe an audio bypass cap?

I think caps are definitely suspect, though.

Re: Could use some pointers on semi working CN70

PostPosted: Mon Nov 06, 2017 5:25 pm
by Purity_Control
Cheers for that, there's a thread on CN70 already that's given me some pointers. :thu:

Re: Could use some pointers on semi working CN70

PostPosted: Mon Nov 06, 2017 11:27 pm
by Plink Floyd
PC can haz osillyscope? With that symptom, the 1st place I'd check is Test Point 71 in the power amp section (bottom right corner) of the schizmo. If you don't see the signal fading there, check it @ TP82 (input to the buffer section, before the volume control. If it's doing it there, we'll dig deeper.

Always good to check the power supply voltages too: TP76 (-46VDC), TP78 (-9VDC), TP84 (+5.4VDC).

Here's the mighty mighty twenty watt power amp chip, btw...

Re: Could use some pointers on semi working CN70

PostPosted: Tue Nov 07, 2017 4:45 pm
by Purity_Control
I don't but I might grab one, would be handy on a lot of levels.

Gonna open this up at the weekend when I have some decent daylight an an hour or two spare, clean it up and check for obvious damage.

Mainly the mint cosmetic condition that sold me on it, so hopefully just an old part here and there rather than anything more serious.